summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libsmbios/Manifest3
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch16
-rw-r--r--sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch19
-rw-r--r--sys-libs/libsmbios/files/libsmbios-fix-pie.patch29
-rw-r--r--sys-libs/libsmbios/libsmbios-2.3.2.ebuild81
-rw-r--r--sys-libs/libsmbios/libsmbios-2.3.3.ebuild78
-rw-r--r--sys-libs/libsmbios/libsmbios-2.4.1.ebuild77
7 files changed, 0 insertions, 303 deletions
diff --git a/sys-libs/libsmbios/Manifest b/sys-libs/libsmbios/Manifest
index c7fd744d19a7..49464a42fb09 100644
--- a/sys-libs/libsmbios/Manifest
+++ b/sys-libs/libsmbios/Manifest
@@ -1,4 +1 @@
-DIST libsmbios-2.3.2.tar.gz 800862 BLAKE2B da888dbe3b3dfa10b39fbc4da90fe643982abc49f756f033d492f29d06631c722da7ec11a2b77780c06a74b7b0e3f70d5d3fc1ce895be7a7c8d136f654a22f7e SHA512 6ef3d71892e157d81fc466689b67c19b83567ee1c4893816da935cfc42738cf958f972eed811aad375fee5bb7d4a6b4e13fb1b5760cd0d7cdb5e65170ebeb129
-DIST libsmbios-2.3.3.tar.gz 801164 BLAKE2B 22d04d4071ec3111d80acbbc10dbd51c15e5f8db06575f3079654da42e33dbbfcb364e1bdc8470d2a66475159da1179cafc9ae5284be0c35c4199dc5b16a1a2e SHA512 d4ee556fc0b734827e1a0def9c9914e79130ce9f164f62a5aa752276772f9ed27874fd8a285b65e016f16f001cdfa23c7c9d228533bb8a03134db90b9cc4f96d
-DIST libsmbios-2.4.1.tar.gz 667796 BLAKE2B 119198783004215c269ae0846aad58fafcdd0ee2148e0014f77271c38511cc61430db2b81c43bbc0da507b40342c923731e06c61829f9604b84b26f7f527b37a SHA512 dd71e45f8047480a669b70efebb9bdbbea4870f96437fc45eb4088fd66331d117b29a65c45cee2e5c4628d0536072a5939eb83f1905857a85bd0567b3d1c22fb
DIST libsmbios-2.4.2.tar.gz 668042 BLAKE2B 2106206dce95e481ae36e033d2abe9f39402368a09686b92fd1de7d85e87ea494514e85bdf1267adb6b52060a4e6bb6001714c5d891a4c0342c814942c0458af SHA512 51d1b11447d50b768658473d01bcb6cc7f9dd5c96c26ec343f222115ffb5047ca1f035a0bfb67f94f53165eaea7a0d9b70cf01f03333a30885bbac153bf761bd
diff --git a/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch b/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch
deleted file mode 100644
index ebe6798bd731..000000000000
--- a/sys-libs/libsmbios/files/libsmbios-2.3.0-doxygen_target.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- libsmbios-2.3.0/Makefile.am
-+++ libsmbios-2.3.0/Makefile.am
-@@ -89,10 +89,12 @@
-
-
- ########## DOCS ################
--all: doxygen
- if HAVE_DOXYGEN
-+all: doxygen
- DOXYGEN_DEPS=out/libsmbios_c/html/index.html out/libsmbios_c++/html/index.html
- doxygen: $(DOXYGEN_DEPS)
-+else
-+all:
- endif
-
- DOT=@DOT@
diff --git a/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch b/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch
deleted file mode 100644
index 4adca14f21d8..000000000000
--- a/sys-libs/libsmbios/files/libsmbios-2.3.3-doxygen_target.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- libsmbios-2.3.3/Makefile.am
-+++ libsmbios-2.3.3/Makefile.am
-@@ -89,13 +89,15 @@
-
-
- ########## DOCS ################
--all: doxygen
- if HAVE_DOXYGEN
-+all: doxygen
- DOXYGEN_DEPS=out/libsmbios_c/html/index.html
- if BUILD_LIBSMBIOS_CXX
- DOXYGEN_DEPS+=out/libsmbios_c++/html/index.html
- endif
- doxygen: $(DOXYGEN_DEPS)
-+else
-+all:
- endif
-
- DOT=@DOT@
diff --git a/sys-libs/libsmbios/files/libsmbios-fix-pie.patch b/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
deleted file mode 100644
index 3ab404e8ea2e..000000000000
--- a/sys-libs/libsmbios/files/libsmbios-fix-pie.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp
-+++ libsmbios-2.2.19/src/bin/dellMediaDirectCtl.cpp
-@@ -183,16 +183,21 @@
- {
- iopl(3);
-
-+ u32 tmpebx;
- __asm__ __volatile__ (
-- // magic port
-- "outb %%al, %%dx \n\t"
--
-+ "movl %%ebx,%[tmpebx]\n\t"
-+ "movl %[ebx],%%ebx\n\t"
-+ // magic port
-+ "outb %%al, %%dx \n\t"
-+ "movl %%ebx,%[ebx]\n\t"
-+ "movl %[tmpebx],%%ebx\n\t"
- : /* output args */
- "=a" (r->eax),
-- "=b" (r->ebx),
-+ [ebx] "=rm" (r->ebx),
- "=c" (r->ecx),
- "=S" (r->esi),
-- "=D" (r->edi)
-+ "=D" (r->edi),
-+ [tmpebx] "+m" (tmpebx)
- : /* input args */
- "0" (r->eax),
- "1" (r->ebx),
diff --git a/sys-libs/libsmbios/libsmbios-2.3.2.ebuild b/sys-libs/libsmbios/libsmbios-2.3.2.ebuild
deleted file mode 100644
index d2777066e17c..000000000000
--- a/sys-libs/libsmbios/libsmbios-2.3.2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools flag-o-matic python-single-r1 versionator
-
-DESCRIPTION="Provide access to (SM)BIOS information"
-HOMEPAGE="http://linux.dell.com/files/libsmbios/"
-SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 OSL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ia64 x86"
-IUSE="doc graphviz nls python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="dev-libs/libxml2
- sys-libs/zlib
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-fix-pie.patch"
- "${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
- "${FILESDIR}/${PN}-2.3.0-doxygen_target.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Don't build yum-plugin - we don't need it
- sed '/yum-plugin/d' -i Makefile.am || die
-
- # Fix version string in build system
- sed "/release_micro_version/s@\[1\]@[$(get_version_component_range 3)]@" \
- -i configure.ac || die
-
- eautoreconf
-}
-
-src_configure() {
- #Remove -O3 for bug #290097
- replace-flags -O3 -O2
-
- econf \
- $(use_enable doc doxygen) \
- $(use_enable graphviz) \
- $(use_enable nls) \
- $(use_enable python) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- if use python ; then
- python_scriptinto /usr/sbin
- python_doscript "${ED%/}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
- fi
-
- insinto /usr/include/
- doins -r src/include/smbios/
-
- einstalldocs
-
- if ! use static-libs ; then
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
- fi
-}
diff --git a/sys-libs/libsmbios/libsmbios-2.3.3.ebuild b/sys-libs/libsmbios/libsmbios-2.3.3.ebuild
deleted file mode 100644
index f6024bfa3475..000000000000
--- a/sys-libs/libsmbios/libsmbios-2.3.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools flag-o-matic python-single-r1 versionator
-
-DESCRIPTION="Provide access to (SM)BIOS information"
-HOMEPAGE="http://linux.dell.com/files/libsmbios/"
-SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 OSL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc graphviz nls python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="dev-libs/libxml2
- sys-libs/zlib
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-fix-pie.patch"
- "${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
- "${FILESDIR}/${PN}-2.3.3-doxygen_target.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Don't build yum-plugin - we don't need it
- sed '/yum-plugin/d' -i Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- #Remove -O3 for bug #290097
- replace-flags -O3 -O2
-
- econf \
- $(use_enable doc doxygen) \
- $(use_enable graphviz) \
- $(use_enable nls) \
- $(use_enable python) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- if use python ; then
- python_scriptinto /usr/sbin
- python_doscript "${ED%/}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
- fi
-
- insinto /usr/include/
- doins -r src/include/smbios/
- doins -r src/include/smbios_c
-
- einstalldocs
-
- if ! use static-libs ; then
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
- fi
-}
diff --git a/sys-libs/libsmbios/libsmbios-2.4.1.ebuild b/sys-libs/libsmbios/libsmbios-2.4.1.ebuild
deleted file mode 100644
index 158c4534ba3c..000000000000
--- a/sys-libs/libsmbios/libsmbios-2.4.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
-
-inherit autotools flag-o-matic python-single-r1 versionator
-
-DESCRIPTION="Provide access to (SM)BIOS information"
-HOMEPAGE="http://linux.dell.com/files/libsmbios/"
-SRC_URI="https://github.com/dell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 OSL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE="doc graphviz nls python static-libs test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="dev-libs/libxml2
- sys-libs/zlib
- nls? ( virtual/libintl )
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- graphviz? ( media-gfx/graphviz )
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.9.6 )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.28-cppunit-tests.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Don't build yum-plugin - we don't need it
- sed '/yum-plugin/d' -i Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- #Remove -O3 for bug #290097
- replace-flags -O3 -O2
-
- local myeconfargs=(
- $(use_enable doc doxygen)
- $(use_enable graphviz)
- $(use_enable nls)
- $(use_enable python)
- $(use_enable static-libs static)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake install DESTDIR="${D}"
-
- if use python ; then
- python_scriptinto /usr/sbin
- python_doscript "${ED%/}"/usr/sbin/smbios-{{keyboard,thermal,token,wakeup,wireless}-ctl,lcd-brightness,passwd,sys-info}
- fi
-
- insinto /usr/include/
- doins -r src/include/smbios_c
-
- einstalldocs
-
- if ! use static-libs ; then
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
- fi
-}