summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/libidn2/Manifest1
-rw-r--r--net-dns/libidn2/libidn2-0.13.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-dns/libidn2/Manifest b/net-dns/libidn2/Manifest
index b380b21c96a1..93ebfbe686e9 100644
--- a/net-dns/libidn2/Manifest
+++ b/net-dns/libidn2/Manifest
@@ -4,3 +4,4 @@ DIST libidn2-0.12-IdnaMappingTable.txt 742564 SHA256 84c8f25d2b58531dada678cbfb7
DIST libidn2-0.12-IdnaTest.txt 422220 SHA256 f56af7d031fddd8264cd95086e360375e3a09e680c8e2d947be469bfa4f4097d SHA512 6ca6f22d01ed88170d8799991129823b55497ffd6d82b724e0f1781317d128e9c72344afe0db3eed50aab3b822a1c36a78da4138f1de421c7ce0da3a4778dda0 WHIRLPOOL 2f1ab3a7bb78cb34ac6ece100111e2cf4b6f021882531b4641ae3472108dce6d2c2ab48b2ab263aa1190e63641e95e5c6688c3c54317db978e49da359ee449d0
DIST libidn2-0.12-idna-tables-6.3.0.txt 162415 SHA256 ac67b5bf7c2de2d3b6e11fa7bf0d7ba54e6457788aec1ebde48739ee084822b7 SHA512 8cb3cc47948a796c2765e220350beccbefda40700bc60fb6b3bcdda24046798e2fee4c6a1a9fc80a3e9bcb3cbaa9a141936d24907eb5a09b43ec94d72fca3de0 WHIRLPOOL d7fffb5a19b0dd602296cb6eb484bf3f55353617c1c2adc9038173156cccf3a8a9eda1c8f5722634ea84099f266b6a036e20694a04a66134b79609b17d6de6a3
DIST libidn2-0.12.tar.gz 1223699 SHA256 5aac6a35546a472b218a1b1257b39e5e829fda489152f6c793064afc5a2f2956 SHA512 044c0a06dca6866d80400a67ef5e9334afa77f55053cd358f107f2d788aa6938c53cb37791d02c58f2e2a00ed7e4167820cd3c544b6a073db41d4877e0a9ca1b WHIRLPOOL c4db646d229ce0ce2d4ddb3c8de074891d2c965051cb3544a41aaafb9181dbea44731794d9e0230f6e199825f0747b45274f65a4fe9e0ddf69d33daf851cf065
+DIST libidn2-0.13.tar.gz 1504713 SHA256 7595f68f189f8bee8c6847a71aab4df2dcb3e24fdc679912c0554043e664bafd SHA512 eb3ed5de8d4554be85b9c85737e1140625e7262599092a6341212fddbaf9b0ee29002a43ec3e46c2931754eb0e4d8a6bb8e38b1bcae23b63769e13ad54077d4b WHIRLPOOL e9a3f922ef4ac0cf7e0dcc452389fec44e11bffae87cc9b57377fc6fddaca254280181ebfad95ba6e2c83ec94d3ca32296baae5bf50dde80adae525a8c115614
diff --git a/net-dns/libidn2/libidn2-0.13.ebuild b/net-dns/libidn2/libidn2-0.13.ebuild
new file mode 100644
index 000000000000..c5848cefce7c
--- /dev/null
+++ b/net-dns/libidn2/libidn2-0.13.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2"
+SRC_URI="
+ mirror://gnu-alpha/libidn/${P}.tar.gz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ sys-apps/help2man
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12-Werror.patch
+ "${FILESDIR}"/${PN}-0.12-examples.patch
+ "${FILESDIR}"/${PN}-0.12-gengetopt.patch
+ "${FILESDIR}"/${PN}-0.12-noinstall.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ # tr46map.c is already present
+ touch gentr46map -r tr46map.c
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+
+ prune_libtool_files
+}