summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.5.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 7e3e38763d1c..0baf64c88ae0 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,4 @@
DIST rawtherapee-5.2.tar.xz 10819936 BLAKE2B 6f4474fdf86efe177861a1a4da2178f75c3589b9d5649d43f7b70a13e51c9658af74fbaea4528e5dc34287b8109cc30608028ca348eb2186d7a2452322139169 SHA512 ed2ff2e96ad4f0c50ebbc8a232d85b8c5b118bc956bc26aa72beb4741f464c46900aa668127fe7bdc963fabb5c2e2931c50cf784d1fc4fbc4dce3090412a1b5d
DIST rawtherapee-5.3.tar.xz 11042548 BLAKE2B 7e0697fc0c0e8b3078ccf1f9079a4adebf7c12e8e91e1d5499f304e93bda1d025540d3744b719535133f249941e2b4dcee98189d20e3009eceeb8531252bfd1a SHA512 8a9a7fe98ba0c8e03e964c809afc90afcc03a31b8b88e0f9e2ab4ecdc1fbe4712231f692d0585d95d638cae7171393e01860296149fc9dfbd86ecb35c3709284
DIST rawtherapee-5.4.tar.xz 11991988 BLAKE2B 625b4e04b82f34d994e0f23f6aea6af4b0a2af2b6a325e916e7b51f8a83b568b65bef47a489be547d1e2437f9637b2ecea0d69d95bfabd53b61b11b46d9e36bc SHA512 6dc9a82202b80675f90eeb8f08c4484700561861f296546ae9425c6e9603f6e84bdc0859896c333d2367cc0b371c6bb6ab2fe36ff3d6f56419cbf18a58d8ef89
+DIST rawtherapee-5.5.tar.xz 12163556 BLAKE2B 6251655b5bcc8b805eda584e386771b14dec15a2d8a96518bdb79d7e31354c78eb263f6964d7f6ffaeb35a127d3f775c9c39dfebf072a0bfc14d284358acd03c SHA512 fcb546ad6e420200a821c89555ec259140995a3bc69429d2ecb648632c02e10ffceebbd7296e879c93b53ad8efa45ea71336d936cd90cead723e70e8932a413a
diff --git a/media-gfx/rawtherapee/rawtherapee-5.5.ebuild b/media-gfx/rawtherapee/rawtherapee-5.5.ebuild
new file mode 100644
index 000000000000..7ac0084fb602
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs flag-o-matic gnome2-utils xdg-utils
+
+MY_P=${P/_rc/-rc}
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="http://www.rawtherapee.com/"
+SRC_URI="http://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="openmp"
+
+RDEPEND="x11-libs/gtk+:3
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/libcanberra[gtk3]
+ media-libs/tiff:0
+ media-libs/libpng:0
+ media-libs/libiptcdata
+ media-libs/lcms:2
+ media-libs/lensfun
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ dev-cpp/gtkmm:3.0"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}