summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/bzr/Manifest1
-rw-r--r--dev-vcs/bzr/bzr-2.7.0.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-vcs/bzr/Manifest b/dev-vcs/bzr/Manifest
index 3215b76c1e41..22edb74ba985 100644
--- a/dev-vcs/bzr/Manifest
+++ b/dev-vcs/bzr/Manifest
@@ -1,2 +1,3 @@
DIST bzr-2.5.1.tar.gz 10451513 SHA256 967346fa6cc52971a8dfd5171ec22e1928cf455fb4317013b05b0915ff927982 SHA512 40700d0f4f61bb1609d85772812249114c9e7af619143aafec97163617cb58828e63bda22abf576704848b479463bb85c0b2dc7e5bb49108f48fa397c7bfe85c WHIRLPOOL 34e90eb01e49840bc2eedba6a664fe936ecc6fcc75e3f350a21a2d868609672984182e50f4f3f127da2e7e8b6dbf229aca587fc8dfe1522cf9bbe1d5c9272288
DIST bzr-2.6.0.tar.gz 11301124 SHA256 0994797182eb828867eee81cccc79480bd2946c99304266bc427b902cf91dab0 SHA512 f40d4380a837321c2ed168d15b0b5d31e9de6df93c0f8f2fd9b16c9351524b0afac5b8744740f587e9704efeb4cc004cae7f35aed47f73b5c796cbe2526af980 WHIRLPOOL a20f45bebb480e0d9d2052373b671ca32f39f52ef3a04800a5d0662248347cbde8a37d24dbaccc6809a7a046646d10bb62ab392302a3dfe983afca0479ce242e
+DIST bzr-2.7.0.tar.gz 11586410 SHA256 0d451227b705a0dd21d8408353fe7e44d3a5069e6c4c26e5f146f1314b8fdab3 SHA512 c39ad3715d865788da74d8de8b469e1dc93d18b6cbcbc569464cdeb9bb2173bf8d7f4f8ee8f7599fbcbbe322817a4c72e785d544e622753699c425c32597d9aa WHIRLPOOL 1058a7a09d1ca3c588c7f06b00ccfc6aedbaaef9eb5c64e1e8399a51771fe5ac0a3fa24b83cf75e39dbe026c9cb0b89902184ee13277a3552688638d87c80737
diff --git a/dev-vcs/bzr/bzr-2.7.0.ebuild b/dev-vcs/bzr/bzr-2.7.0.ebuild
new file mode 100644
index 000000000000..7227580d728e
--- /dev/null
+++ b/dev-vcs/bzr/bzr-2.7.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads,ssl,xml"
+
+MY_P="${PN}-${PV}"
+
+DESCRIPTION="Bazaar is a next generation distributed version control system"
+HOMEPAGE="http://bazaar-vcs.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="curl doc +sftp test"
+PLOCALES="ar ast bs ca cs de el en_AU en_GB es fa fo fr gl he id it ja ko ms my nb nl oc pl pt_BR ro ru sco si sk sr sv tr ug uk vi zh_CN"
+
+inherit bash-completion-r1 distutils-r1 eutils flag-o-matic versionator l10n
+SERIES=$(get_version_component_range 1-2)
+SRC_URI="https://launchpad.net/bzr/${SERIES}/${PV}/+download/${MY_P}.tar.gz"
+
+RDEPEND="curl? ( dev-python/pycurl[${PYTHON_USEDEP}] )
+ sftp? ( dev-python/paramiko[${PYTHON_USEDEP}] )"
+
+DEPEND="test? (
+ ${RDEPEND}
+ >=dev-python/pyftpdlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/subunit
+ >=dev-python/testtools-0.9.5[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Fails tests bug#487216
+# Upstream is not exactly keen on fixing it
+RESTRICT="test"
+
+python_configure_all() {
+ rm_loc() {
+ rm "${S}"/po/$1.po || die
+ }
+ l10n_for_each_disabled_locale_do rm_loc
+ # Generate the locales first to avoid a race condition.
+ esetup.py build_mo
+}
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # Some tests expect the usual pyc compiling behaviour.
+ local -x PYTHONDONTWRITEBYTECODE
+
+ # Define tests which are known to fail below.
+ local skip_tests="("
+ # https://bugs.launchpad.net/bzr/+bug/850676
+ skip_tests+="per_transport.TransportTests.test_unicode_paths.*"
+ skip_tests+=")"
+ if [[ -n ${skip_tests} ]]; then
+ einfo "Skipping tests known to fail: ${skip_tests}"
+ fi
+
+ LC_ALL="C" "${PYTHON}" bzr --no-plugins selftest -v \
+ ${skip_tests:+-x} "${skip_tests}" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # Fixup manpages manually; passing --install-data causes locales to be
+ # installed in /usr/share/share/locale
+ dodir /usr/share
+ mv "${ED%/}"/usr/{man,share/man} || die
+
+ dodoc doc/*.txt
+
+ if use doc; then
+ docinto developers
+ dodoc -r doc/developers/* || die
+ for doc in mini-tutorial tutorials user-{guide,reference}; do
+ docinto ${doc}
+ dodoc -r doc/en/${doc}/* || die
+ done
+ fi
+
+ dobashcomp contrib/bash/bzr || die
+}