summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild')
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild
deleted file mode 100644
index 32334a14e2a2..000000000000
--- a/app-accessibility/at-spi2-core/at-spi2-core-2.26.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 multilib-minimal
-
-DESCRIPTION="D-Bus accessibility specifications and registration daemon"
-HOMEPAGE="https://wiki.gnome.org/Accessibility"
-
-LICENSE="LGPL-2+"
-SLOT="2"
-IUSE="X +introspection"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-
-# x11-libs/libSM is needed until upstream #719808 is solved either
-# making the dep unneeded or fixing their configure
-# Only libX11 is optional right now
-RDEPEND="
- >=dev-libs/glib-2.36:2[${MULTILIB_USEDEP}]
- >=sys-apps/dbus-1[${MULTILIB_USEDEP}]
- introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
- X? (
- x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libXtst[${MULTILIB_USEDEP}]
- x11-libs/libXi[${MULTILIB_USEDEP}]
- )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.25
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig[${MULTILIB_USEDEP}]
-"
-
-PATCHES=(
- # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
- "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
- "${FILESDIR}/${PV}-fix-inverted-logic.patch"
-)
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- gnome2_src_configure \
- $(multilib_native_use_enable introspection) \
- $(use_enable X x11)
-
- # work-around gtk-doc out-of-source brokedness
- if multilib_is_native_abi; then
- ln -s "${S}"/doc/libatspi/html doc/libatspi/html || die
- fi
-}
-
-multilib_src_compile() { gnome2_src_compile; }
-multilib_src_install() { gnome2_src_install; }