summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild')
-rw-r--r--app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild b/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
index c2d113a7a6c6..90155ff033cd 100644
--- a/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
+++ b/app-accessibility/speech-tools/speech-tools-2.5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P=${P/speech-/speech_}
PATCHSET="r3"
@@ -99,6 +99,11 @@ src_configure() {
}
src_compile() {
+ # Lacks prototypes, bug #881863
+ append-cflags -std=gnu89
+ # Uses 'register' keyword removed in C++17, bug #894184
+ append-cxxflags -std=c++14
+
emake -j1 \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \