summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-3.20.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index b1653e65552c..303b112724de 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,2 +1,3 @@
DIST orca-3.18.2.tar.xz 2213548 SHA256 986244af7a0891b758eb8e772bc61d72483808e7e9c790360f9f389045d7262a SHA512 ec1210cea7a540bd931f7ede45c173829e780a4da4e61245920d15bb11b62d803771e32b791b2d0c307e15a8ef61b619b5e79e9909bf438a94252842a0dd8613 WHIRLPOOL 31475d1eacbf322cdd49d286c3585d97c93de08f92b0533fa58905d4ea089272bc16e8bb748041cc6f27dd54c19996b3d72993c5b148b3c8e6c873f9e452fe98
DIST orca-3.20.2.tar.xz 2313164 SHA256 8c90403c4ae8bb0a4b240d1e784b61ee56de42df781520c912b298c10ae05785 SHA512 27594b9b0fa9343057a854e8cfff7ab074e084c3f210c1bf1f4310363b4738ce6af5b4f62ef15ed58093af27e7eaad2e030c08e990cf462624e5fb2c8329fd0c WHIRLPOOL 473f7fd8b5dedb8034774604a38b97dcdc3b2e3c346e89f0b36343b18e69bffac7f98927bc069b3ac20c969c2dae09087f2612dacb09b98952fc299e3d340c76
+DIST orca-3.20.3.tar.xz 2312864 SHA256 86a03b504f626e39247694d8d76c272a298874887a40bd044f8a535b8d689fd7 SHA512 5dc04cec821f7a47be0cb6e820a531e9753dd24685771e6b70488d30502bc111a4b107f8d63440139bfa9579015f224f6fda6cd8f0ecc0fc7fbfa3ce684d75f9 WHIRLPOOL c96795a9d6f9486cce7150041c5608d5beb39b8fdd33c7312beee40100aba67f3846f4c449ea8ae8b393c334be27197dbb5b2415d8a8a38cba9d775144b1bbfd
diff --git a/app-accessibility/orca/orca-3.20.3.ebuild b/app-accessibility/orca/orca-3.20.3.ebuild
new file mode 100644
index 000000000000..f78416849e54
--- /dev/null
+++ b/app-accessibility/orca/orca-3.20.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4,5} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.12:2
+ >=app-accessibility/at-spi2-core-2.12:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ media-libs/gstreamer:1.0
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}