summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cdist/cdist-7.0.0.ebuild')
-rw-r--r--app-admin/cdist/cdist-7.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/cdist/cdist-7.0.0.ebuild b/app-admin/cdist/cdist-7.0.0.ebuild
new file mode 100644
index 000000000000..074a43f466ea
--- /dev/null
+++ b/app-admin/cdist/cdist-7.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.cdi.st/ https://code.ungleich.ch/ungleich-public/cdist"
+SRC_URI="https://code.ungleich.ch/ungleich-public/cdist/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+distutils_enable_sphinx docs/src dev-python/sphinx-rtd-theme
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ echo "VERSION='${PV}'" > cdist/version.py || die "Failed to set version"
+ distutils-r1_python_prepare_all
+}