summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild')
-rw-r--r--app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild b/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild
new file mode 100644
index 000000000000..9d5192573345
--- /dev/null
+++ b/app-admin/filebeat-bin/filebeat-bin-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN/-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="amd64? ( https://download.elastic.co/beats/${MY_PN}/${MY_P}-x86_64.tar.gz )
+ x86? ( https://download.elastic.co/beats/${MY_PN}/${MY_P}-i686.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ if use amd64; then
+ S="${WORKDIR}/${MY_P}-x86_64"
+ elif use x86; then
+ S="${WORKDIR}/${MY_P}-i686"
+ fi
+
+ default
+}
+
+src_install() {
+ keepdir /etc/${MY_PN}
+ keepdir /var/lib/${MY_PN}
+
+ fperms 0750 /var/lib/${MY_PN}
+
+ insinto /etc/${MY_PN}
+ doins "${FILESDIR}/filebeat.yml.example"
+
+ newconfd "${FILESDIR}/${MY_PN}.confd" ${MY_PN}
+ newinitd "${FILESDIR}/${MY_PN}.initd" ${MY_PN}
+
+ dobin ${MY_PN}
+}
+
+pkg_postinst() {
+ if [[ ! -e /etc/${MY_PN}/${MY_PN}.yml ]]; then
+ elog "Before starting filebeat, you need to create a configuration file at:"
+ elog "/etc/${MY_PN}/${MY_PN}.yml"
+ fi
+}