summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/haskell-updater/haskell-updater-1.3.2.ebuild')
-rw-r--r--app-admin/haskell-updater/haskell-updater-1.3.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-admin/haskell-updater/haskell-updater-1.3.2.ebuild b/app-admin/haskell-updater/haskell-updater-1.3.2.ebuild
deleted file mode 100644
index 544312532d31..000000000000
--- a/app-admin/haskell-updater/haskell-updater-1.3.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-CABAL_FEATURES="bin nocabaldep"
-inherit haskell-cabal
-
-DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
-HOMEPAGE="https://wiki.haskell.org/Gentoo#haskell-updater"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-
-DEPEND=">=dev-lang/ghc-6.12.1"
-
-# Need a lower version for portage to get --keep-going
-RDEPEND="|| ( >=sys-apps/portage-2.1.6
- sys-apps/pkgcore )"
-
-src_prepare() {
- default
-
- if use prefix; then
- sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
- "${S}/Distribution/Gentoo/Packages.hs" || die
-
- sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
- "${S}/Distribution/Gentoo/GHC.hs" || die
- fi
-}
-
-src_configure() {
- cabal_src_configure \
- --bindir="${EPREFIX}/usr/sbin" \
- --constraint="Cabal == $(cabal-version)"
-}
-
-src_install() {
- cabal_src_install
-
- dodoc TODO
-}