summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild')
-rw-r--r--app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild b/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..f8ad938f5c05
--- /dev/null
+++ b/app-admin/pass-otp/pass-otp-1.2.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="A pass extension for managing one-time-password (OTP) tokens"
+HOMEPAGE="https://github.com/tadfisher/pass-otp"
+SRC_URI="https://github.com/tadfisher/pass-otp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-tcltk/expect:* )"
+
+RDEPEND="
+ >=app-admin/pass-1.7
+ sys-auth/oath-toolkit
+ media-gfx/qrencode
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake install DESTDIR="${D}" BASHCOMPDIR="$(get_bashcompdir)"
+}