summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ps_mem/ps_mem-3.14-r1.ebuild')
-rw-r--r--app-admin/ps_mem/ps_mem-3.14-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/ps_mem/ps_mem-3.14-r1.ebuild b/app-admin/ps_mem/ps_mem-3.14-r1.ebuild
new file mode 100644
index 000000000000..b5474c4c3e05
--- /dev/null
+++ b/app-admin/ps_mem/ps_mem-3.14-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A utility to report core memory usage per program"
+HOMEPAGE="https://github.com/pixelb/ps_mem"
+SRC_URI="https://github.com/pixelb/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc64 sparc x86"
+
+python_install() {
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}