summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/selint/selint-1.2.0.ebuild')
-rw-r--r--app-admin/selint/selint-1.2.0.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/app-admin/selint/selint-1.2.0.ebuild b/app-admin/selint/selint-1.2.0.ebuild
index d4b097ca5ddc..d8f4a20dbd0a 100644
--- a/app-admin/selint/selint-1.2.0.ebuild
+++ b/app-admin/selint/selint-1.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Static code analysis of refpolicy style SELinux policy"
HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
else
SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="amd64 x86"
+ KEYWORDS="amd64 ~arm x86"
fi
LICENSE="Apache-2.0"
@@ -23,7 +23,8 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/confuse:=
- dev-libs/uthash"
+ dev-libs/uthash
+ elibc_musl? ( sys-libs/fts-standalone )"
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
@@ -35,5 +36,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-libs "-lfts"
+
econf $(use_with test check)
}