summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/selint/selint-1.2.1.ebuild')
-rw-r--r--app-admin/selint/selint-1.2.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-admin/selint/selint-1.2.1.ebuild b/app-admin/selint/selint-1.2.1.ebuild
index db21da9231ac..e32de56f5c31 100644
--- a/app-admin/selint/selint-1.2.1.ebuild
+++ b/app-admin/selint/selint-1.2.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
+inherit flag-o-matic
+
DESCRIPTION="Static code analysis of refpolicy style SELinux policy"
HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
@@ -11,7 +13,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
else
SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="amd64 ~arm x86"
fi
LICENSE="Apache-2.0"
@@ -21,7 +23,8 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/confuse:=
- dev-libs/uthash"
+ dev-libs/uthash
+ elibc_musl? ( sys-libs/fts-standalone )"
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
@@ -33,5 +36,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-libs "-lfts"
+
econf $(use_with test check)
}