summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/selint/selint-9999.ebuild')
-rw-r--r--app-admin/selint/selint-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-admin/selint/selint-9999.ebuild b/app-admin/selint/selint-9999.ebuild
index edf31eb39cb0..358b8be6eee1 100644
--- a/app-admin/selint/selint-9999.ebuild
+++ b/app-admin/selint/selint-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-inherit toolchain-funcs
+inherit flag-o-matic
-DESCRIPTION="Policy Analysis Tools for SELinux"
+DESCRIPTION="Static code analysis of refpolicy style SELinux policy"
HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
if [[ ${PV} == 9999 ]] ; then
@@ -23,7 +23,8 @@ RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/confuse:=
- dev-libs/uthash"
+ dev-libs/uthash
+ elibc_musl? ( sys-libs/fts-standalone )"
DEPEND="${RDEPEND}
test? ( dev-libs/check )"
@@ -35,5 +36,7 @@ src_prepare() {
}
src_configure() {
+ use elibc_musl && append-libs "-lfts"
+
econf $(use_with test check)
}