summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/setools/setools-9999.ebuild')
-rw-r--r--app-admin/setools/setools-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 2ab393f30dcc..ec3d11050109 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+EAPI="8"
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -22,34 +24,34 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="test infoflow X"
+IUSE="test X"
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
+ >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
>=sys-libs/libsepol-3.2:=
>=sys-libs/libselinux-3.2:=
- infoflow? ( >=dev-python/networkx-2.0[${PYTHON_USEDEP}] )
X? (
dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}"
BDEPEND=">=dev-python/cython-0.27[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- >=dev-python/networkx-2.0[${PYTHON_USEDEP}]
sys-apps/checkpolicy
)"
+distutils_enable_tests pytest
+
python_prepare_all() {
- sed -i "s/'-Werror', //" "${S}"/setup.py || die "failed to remove Werror"
sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
die "failed to set lib_dirs"
- use X || local PATCHES=( "${FILESDIR}"/setools-4.4.0-remove-gui.patch )
+ use X || PATCHES+=( "${FILESDIR}"/setools-4.4.2-remove-gui.patch )
distutils-r1_python_prepare_all
}
python_test() {
- esetup.py test
+ rm -rf setools || die
+ epytest
}