summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/stow/stow-2.3.1.ebuild')
-rw-r--r--app-admin/stow/stow-2.3.1.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/app-admin/stow/stow-2.3.1.ebuild b/app-admin/stow/stow-2.3.1.ebuild
index 834867c86051..2c8d731bfc35 100644
--- a/app-admin/stow/stow-2.3.1.ebuild
+++ b/app-admin/stow/stow-2.3.1.ebuild
@@ -1,26 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit perl-functions
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/adamspiers.asc
+inherit perl-functions verify-sig
DESCRIPTION="GNU Stow is a symlink farm manager"
-HOMEPAGE="https://www.gnu.org/software/stow/"
-SRC_URI="mirror://gnu/stow/${P}.tar.gz"
+HOMEPAGE="https://www.gnu.org/software/stow/ https://git.savannah.gnu.org/cgit/stow.git"
+SRC_URI="mirror://gnu/stow/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/stow/${P}.tar.bz2.sig )"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~hppa ~mips ~ppc ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="dev-lang/perl
+RDEPEND="dev-lang/perl:="
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-perl/IO-stringy
virtual/perl-Test-Harness
dev-perl/Test-Output
- )"
-RDEPEND="dev-lang/perl:="
+ )
+ verify-sig? ( sec-keys/openpgp-keys-adamspiers )
+"
src_configure() {
perl_set_version