summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible/ansible-9999.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index 175ebc5dcfbf..4284a69a020e 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 git-r3 readme.gentoo
+inherit distutils-r1 eutils git-r3 readme.gentoo
DESCRIPTION="Radically simple deployment, model-driven configuration management, and command execution framework"
HOMEPAGE="http://ansible.com/"
@@ -43,6 +43,13 @@ python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
+python_compile_all() {
+ local _man
+ for _man in ansible{,-{galaxy,playbook,pull,vault}}; do
+ a2x -f manpage docs/man/man1/${_man}.1.asciidoc.in || die "Failed generating man page (${_man})"
+ done
+}
+
python_install_all() {
EXAMPLES=( examples )
distutils-r1_python_install_all