summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/files/50puppet-mode-gentoo.el6
-rw-r--r--app-admin/puppet/puppet-4.10.12.ebuild23
2 files changed, 2 insertions, 27 deletions
diff --git a/app-admin/puppet/files/50puppet-mode-gentoo.el b/app-admin/puppet/files/50puppet-mode-gentoo.el
deleted file mode 100644
index 64c38ae5a31d..000000000000
--- a/app-admin/puppet/files/50puppet-mode-gentoo.el
+++ /dev/null
@@ -1,6 +0,0 @@
-
-;;; puppet-mode site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-(autoload 'puppet-mode "puppet-mode" "Major mode for editing puppet manifests")
-(add-to-list 'auto-mode-alist '("\\.pp$" . puppet-mode))
diff --git a/app-admin/puppet/puppet-4.10.12.ebuild b/app-admin/puppet/puppet-4.10.12.ebuild
index 77c0ff21fd5d..7e3b54d90ab3 100644
--- a/app-admin/puppet/puppet-4.10.12.ebuild
+++ b/app-admin/puppet/puppet-4.10.12.ebuild
@@ -9,7 +9,7 @@ USE_RUBY="ruby23 ruby24"
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit xemacs-elisp-common eutils user ruby-fakegem versionator
+inherit eutils user ruby-fakegem versionator
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -46,8 +46,6 @@ ruby_add_rdepend "
# >=dev-ruby/webmock-1.24:0
# )"
-DEPEND+=" ${DEPEND}
- xemacs? ( app-editors/xemacs )"
RDEPEND+=" ${RDEPEND}
rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
selinux? (
@@ -106,13 +104,7 @@ all_ruby_prepare() {
}
all_ruby_compile() {
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs
- cp ext/emacs/* ext/xemacs/
- xemacs-elisp-compile ext/xemacs/puppet-mode.el
- fi
+ :
}
each_ruby_install() {
@@ -150,11 +142,6 @@ all_ruby_install() {
fowners -R :puppet /etc/puppetlabs
fowners -R :puppet /var/lib/puppet
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
if use ldap ; then
insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi
@@ -187,10 +174,4 @@ pkg_postinst() {
elog
fi
done
-
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use xemacs && xemacs-elisp-site-regen
}