summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apache-tools/Manifest1
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.17.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/app-admin/apache-tools/Manifest b/app-admin/apache-tools/Manifest
index 5ea9393ffc80..451c580ddb96 100644
--- a/app-admin/apache-tools/Manifest
+++ b/app-admin/apache-tools/Manifest
@@ -1,4 +1,3 @@
DIST httpd-2.2.31.tar.bz2 5610489 SHA256 f32f9d19f535dac63b06cb55dfc023b40dcd28196b785f79f9346779e22f26ac SHA512 5aa47d4b76f692bbd8b309135ff99152df98cf69b505b9daf3f13f7f2a31443eaf4995161adfbc47a133b4d0e091fda2d95fc6b87a956f0ada18d7466ee28e74 WHIRLPOOL a2e3e53c51719cb6f7e641b41788cd89ce7b4d2ea105b403bfa3b3d4479b69c5604228269062f66722594e105e91121d05b1c9f27ca7dc4ecfcf339da8b8375c
DIST httpd-2.4.16.tar.bz2 5101005 SHA256 ac660b47aaa7887779a6430404dcb40c0b04f90ea69e7bd49a40552e9ff13743 SHA512 039750ff962c08a7261896acc8272e59874d066f7d52721aaf967ddb737fc5716acc47e1effaf7c4d156ba61bc393e0738f64f8e89cc277ba2651e0f61d56628 WHIRLPOOL f67a4449409cd1a50fcdf4d192a3a0c90e6e3483269d19e9f0454557cbfbda7fb3535063e1738de60d6f524e22eac7fc159d2abe5a60952219c1b01ee143ae05
-DIST httpd-2.4.17.tar.bz2 5157721 SHA256 331e035dec81d3db95b048f036f4d7b1a97ec8daa5b377bde42d4ccf1f2eb798 SHA512 d818dbd4b138db592a98fecdf5ae13dfadc19f9553e98bdafbdadd4693ae19bb44c96c8c279e9546978bbce55b9286ce3c4ae69cf701a9812be134a3a517b1f6 WHIRLPOOL f18dd92091e0d7f051f55276dc99656b299f3aaff5375d2fe286e18c33cfeb6887db9c792a426e88655dc0523e66008b2fc534ee1a5ae5b2ae5000bef1509aa8
DIST httpd-2.4.18.tar.bz2 5181291 SHA256 0644b050de41f5c9f67c825285049b144690421acb709b06fe53eddfa8a9fd4c SHA512 8e342cc447313c07275869381c2d6f2314a96547f0c86ee1c617975d0f7ad8efb47113ab5995c733108ae4dec31ad79847e397ecea859b60414ffe1680617a31 WHIRLPOOL e0ae6b8581e2993e0f873d8928e3b54f1df750f29e82d2f1308376af440308c56e89dfb3ec051cdf164a271580ccac71ebc5b038e23ca65a9221fdfc08b47b41
diff --git a/app-admin/apache-tools/apache-tools-2.4.17.ebuild b/app-admin/apache-tools/apache-tools-2.4.17.ebuild
deleted file mode 100644
index ae3aeaf8f1bd..000000000000
--- a/app-admin/apache-tools/apache-tools-2.4.17.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit flag-o-matic eutils multilib toolchain-funcs
-
-DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
-HOMEPAGE="http://httpd.apache.org/"
-SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
-IUSE="libressl ssl"
-RESTRICT="test"
-
-RDEPEND=">=dev-libs/apr-1.5.0:1
- dev-libs/apr-util:1
- dev-libs/expat
- dev-libs/libpcre
- kernel_linux? ( sys-apps/util-linux )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-S="${WORKDIR}/httpd-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.4.7-Makefile.patch #459446
-
- # This package really should upgrade to using pcre's .pc file.
- cat <<-\EOF >"${T}"/pcre-config
- #!/bin/sh
- [ "${flag}" = "--version" ] && set -- --modversion
- exec ${PKG_CONFIG} libpcre "$@"
- EOF
- chmod a+x "${T}"/pcre-config
-}
-
-src_configure() {
- # Brain dead check.
- tc-is-cross-compiler && export ap_cv_void_ptr_lt_long="no"
-
- tc-export PKG_CONFIG
-
- # Instead of filtering --as-needed (bug #128505), append --no-as-needed
- append-ldflags $(no-as-needed)
-
- # econf overwrites the stuff from config.layout.
- ac_cv_path_PKGCONFIG=${PKG_CONFIG} \
- econf \
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)/apache2/modules \
- --sbindir="${EPREFIX}"/usr/sbin \
- --with-perl="${EPREFIX}"/usr/bin/perl \
- --with-expat="${EPREFIX}"/usr \
- --with-z="${EPREFIX}"/usr \
- --with-apr="${SYSROOT}${EPREFIX}"/usr \
- --with-apr-util="${SYSROOT}${EPREFIX}"/usr \
- --with-pcre="${T}"/pcre-config \
- $(use_enable ssl) \
- $(usex ssl '--with-ssl="${EPREFIX}"/usr' '')
- sed -i \
- -e '/^LTFLAGS/s:--silent::' \
- build/rules.mk build/config_vars.mk || die
-}
-
-src_compile() {
- emake -C support
-}
-
-src_install() {
- emake -C support DESTDIR="${D}" install
- dodoc CHANGES
- doman docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
- docs/man/{htcacheclean,rotatelogs}.8
-
- # Providing compatiblity symlinks for #177697 (which we'll stop to install
- # at some point).
- pushd "${ED}"/usr/sbin >/dev/null || die
- local i
- for i in *; do
- dosym ${i} /usr/sbin/${i}2
- done
- popd >/dev/null || die
-
- # Provide a symlink for ab-ssl
- if use ssl; then
- dosym ab /usr/bin/ab-ssl
- dosym ab /usr/bin/ab2-ssl
- fi
-}