summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/keepass/Manifest2
-rw-r--r--app-admin/keepass/keepass-2.28.ebuild105
-rw-r--r--app-admin/keepass/keepass-2.29.ebuild105
3 files changed, 0 insertions, 212 deletions
diff --git a/app-admin/keepass/Manifest b/app-admin/keepass/Manifest
index 2d47051a756a..ccf14817f6b0 100644
--- a/app-admin/keepass/Manifest
+++ b/app-admin/keepass/Manifest
@@ -1,3 +1 @@
-DIST KeePass-2.28-Source.zip 3532385 SHA256 2bd3291308fbb592ee8da21c42457320f81d00eda189c9ee39f03a12783ff91b SHA512 3fc1813076f4a205a6d970d3b9d1abfdfb8ea03099523dc8f7d775f5a4210002323bd8cbeba216acecf84032aa8504e752063880b87190935cb45d646badd672 WHIRLPOOL 954c677a10dad6bdf470dd29e777896806d1f5137711dea3e9ac7c2fd9ddc98042c9911fd10cf3c0f7838f3eebe40676564b4efcb43e3d2eb8b8d2bb0866fd07
-DIST KeePass-2.29-Source.zip 4762221 SHA256 b5582eb96611726a70b523c156c89dfb83ae80ce051a4f57bb0b7a6fbf023a14 SHA512 3a682be8f54fdaad7d299620f5f4821753f27716204f3aceac6e0e078a885dd427e0498ad78f5cdf29946d4821bd29c9f1b6f808d143afa225ffdf975d242047 WHIRLPOOL 3a00ad16a7b0c62df142edc1577c8fb04834a799708e744a808e1fefad4cf55ceb52cb0a68f0143eb68600e3c5bb99371a765fa8c5e5c16f8d0ccdd78f5f403b
DIST KeePass-2.30-Source.zip 4767753 SHA256 4a3c3c217bc05b13bf903612b89a09b67ed1df68fdecd83324f2ef372313e9e4 SHA512 05404f273f6a7df33887b036aa0dba335124a7b2ae30b61957f8dc9c959cdd3342fdfa22a7d59ba5e9180f039fed5ecbac0a3154eb9d342a5a3a8a057d763182 WHIRLPOOL 4ddec9e592724b60724a2deaaf959dacc91f77d1ae97dd07af940f8efd882a008b4424ba68a4fcbd9ebe8d75c2b8a9a644ff7144ed593cfb3f0e361c0364a780
diff --git a/app-admin/keepass/keepass-2.28.ebuild b/app-admin/keepass/keepass-2.28.ebuild
deleted file mode 100644
index a7f63724749b..000000000000
--- a/app-admin/keepass/keepass-2.28.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils fdo-mime gnome2-utils mono-env multilib
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="http://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND=">=dev-lang/mono-2.10.5"
-RDEPEND="${COMMON_DEPEND}
- dev-dotnet/libgdiplus[cairo]"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
- # Remove Windows-specific things
- pushd Build > /dev/null || die
- . PrepMonoDev.sh || die
- popd > /dev/null || die
-
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass
- epatch "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch"
-}
-
-src_compile() {
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto /usr/share/${PN}/XSL
- doins Ext/XSL/*
-
- insinto /usr/$(get_libdir)/${PN}/
- exeinto /usr/$(get_libdir)/${PN}/
- doins Ext/KeePass.exe.config
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages/
- doins "${FILESDIR}/${PN}.xml"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype)"
- fi
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-}
diff --git a/app-admin/keepass/keepass-2.29.ebuild b/app-admin/keepass/keepass-2.29.ebuild
deleted file mode 100644
index 55cdd13ba19c..000000000000
--- a/app-admin/keepass/keepass-2.29.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils fdo-mime gnome2-utils mono-env multilib
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="http://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="aot"
-
-COMMON_DEPEND=">=dev-lang/mono-2.10.5"
-RDEPEND="${COMMON_DEPEND}
- dev-dotnet/libgdiplus[cairo]"
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
- # Remove Windows-specific things
- pushd Build > /dev/null || die
- . PrepMonoDev.sh || die
- popd > /dev/null || die
-
- # KeePass looks for some XSL files in the same folder as the executable,
- # we prefer to have it in /usr/share/KeePass
- epatch "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch"
-}
-
-src_compile() {
- # Build with Release target
- xbuild /target:KeePass /property:Configuration=Release || die
-
- # Run Ahead Of Time compiler on the binary
- if use aot; then
- cp Ext/KeePass.exe.config Build/KeePass/Release/
- mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
- fi
-}
-
-src_install() {
- # Wrapper script to launch mono
- make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
- # Some XSL files
- insinto /usr/share/${PN}/XSL
- doins Ext/XSL/*
-
- insinto /usr/$(get_libdir)/${PN}/
- exeinto /usr/$(get_libdir)/${PN}/
- doins Ext/KeePass.exe.config
- # Default configuration, simply says to use user-specific configuration
- doins Ext/KeePass.config.xml
-
- # The actual executable
- doexe Build/KeePass/Release/KeePass.exe
-
- # Copy the AOT compilation result
- if use aot; then
- doexe Build/KeePass/Release/KeePass.exe.so
- fi
-
- # Prepare the icons
- newicon -s 256 Ext/Icons/Finals/plockb.png "${PN}.png"
- newicon -s 256 -t gnome -c mimetypes Ext/Icons/Finals/plockb.png "application-x-${PN}2.png"
-
- # Create a desktop entry and associate it with the KeePass mime type
- make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"
-
- # MIME descriptor for .kdbx files
- insinto /usr/share/mime/packages/
- doins "${FILESDIR}/${PN}.xml"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-
- if ! has_version x11-misc/xdotool ; then
- elog "Optional dependencies:"
- elog " x11-misc/xdotool (enables autotype)"
- fi
-
- elog "Some systems may experience issues with copy and paste operations."
- elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- fdo-mime_mime_database_update
- fdo-mime_desktop_database_update
-}