summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/whowatch/whowatch-99999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/whowatch/whowatch-99999.ebuild b/app-admin/whowatch/whowatch-99999.ebuild
new file mode 100644
index 000000000000..73c452f9523b
--- /dev/null
+++ b/app-admin/whowatch/whowatch-99999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop git-r3
+
+DESCRIPTION="Displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/ https://github.com/mtsuszycki/whowatch/"
+EGIT_REPO_URI="https://github.com/mtsuszycki/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog.old NEWS PLUGINS.readme README.md TODO
+ domenu ${PN}.desktop
+}