summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/arj/arj-3.10.22-r8.ebuild')
-rw-r--r--app-arch/arj/arj-3.10.22-r8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/arj/arj-3.10.22-r8.ebuild b/app-arch/arj/arj-3.10.22-r8.ebuild
new file mode 100644
index 000000000000..411fee4059d2
--- /dev/null
+++ b/app-arch/arj/arj-3.10.22-r8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+PATCH_LEVEL=15
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Utility for opening arj archives"
+HOMEPAGE="https://arj.sourceforge.net/"
+SRC_URI="
+ mirror://debian/pool/main/a/arj/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/a/arj/${MY_P}-${PATCH_LEVEL}.debian.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+PATCHES=(
+ "${FILESDIR}/${P}-implicit-declarations.patch"
+ "${FILESDIR}/${P}-glibc2.10.patch"
+ "${WORKDIR}"/debian/patches/
+ "${FILESDIR}/${P}-darwin.patch"
+)
+
+DOCS=( doc/compile.txt doc/debug.txt doc/glossary.txt doc/rev_hist.txt doc/xlation.txt )
+
+src_prepare() {
+ default
+ cd gnu || die 'failed to change to the "gnu" directory'
+ echo -n "" > stripgcc.lnk || die "failed to disable stripgcc.lnk"
+
+ eautoreconf
+}
+
+src_configure() {
+ cd gnu || die 'failed to change to the "gnu" directory'
+ tc-export CC # Uses autoconf but not automake.
+ econf
+}