summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild60
1 files changed, 41 insertions, 19 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 68bd7f1fb826..53768510bba9 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -1,35 +1,53 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL="1"
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit cmake-multilib distutils-r1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit cmake-multilib distutils-r1 flag-o-matic
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
fi
DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
+HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
-IUSE="python static-libs test"
-
+IUSE="python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
RESTRICT="!test? ( test )"
-DOCS=( README.md CONTRIBUTING.md )
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ python? (
+ ${DISTUTILS_DEPS}
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/unittest-or-fail[${PYTHON_USEDEP}]
+ ' 3.{9..11})
+ )
+ )
+"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
+DOCS=( README.md CONTRIBUTING.md )
src_prepare() {
cmake_src_prepare
@@ -42,26 +60,23 @@ multilib_src_configure() {
)
cmake_src_configure
}
+
src_configure() {
+ append-lfs-flags
+
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
-multilib_src_compile() {
- cmake_src_compile
-}
src_compile() {
cmake-multilib_src_compile
use python && distutils-r1_src_compile
}
python_test() {
- esetup.py test || die
+ eunittest -s python -p "*_test.py"
}
-multilib_src_test() {
- cmake_src_test
-}
src_test() {
cmake-multilib_src_test
use python && distutils-r1_src_test
@@ -69,8 +84,15 @@ src_test() {
multilib_src_install() {
cmake_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
}
+
multilib_src_install_all() {
use python && distutils-r1_src_install
+
+ doman docs/brotli.1
+
+ local page
+ for page in constants decode encode types ; do
+ newman docs/${page}.h.3 ${PN}_${page}.h.3
+ done
}