summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/brotli/brotli-9999.ebuild')
-rw-r--r--app-arch/brotli/brotli-9999.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 95d260803795..53768510bba9 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -3,11 +3,12 @@
EAPI=8
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL="1"
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
-inherit cmake-multilib distutils-r1
+inherit cmake-multilib distutils-r1 flag-o-matic
if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
@@ -17,9 +18,6 @@ else
SRC_URI="
https://github.com/google/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${P}.testdata.tar.xz
- )
"
fi
@@ -28,7 +26,7 @@ HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
-IUSE="python static-libs test"
+IUSE="python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -41,14 +39,16 @@ DEPEND="
BDEPEND="
python? (
${DISTUTILS_DEPS}
- test? ( dev-python/unittest-or-fail[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/unittest-or-fail[${PYTHON_USEDEP}]
+ ' 3.{9..11})
+ )
)
"
DOCS=( README.md CONTRIBUTING.md )
-PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
-
src_prepare() {
cmake_src_prepare
use python && distutils-r1_src_prepare
@@ -62,6 +62,8 @@ multilib_src_configure() {
}
src_configure() {
+ append-lfs-flags
+
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
@@ -82,9 +84,6 @@ src_test() {
multilib_src_install() {
cmake_src_install
- if ! use static-libs; then
- rm "${ED}"/usr/$(get_libdir)/*.a || die
- fi
}
multilib_src_install_all() {