summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lz4')
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/lz4-1.8.0.ebuild37
-rw-r--r--app-arch/lz4/lz4-9999.ebuild2
3 files changed, 38 insertions, 2 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index 53bbdbb9e41b..0e6aa7dc3a1b 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1,4 +1,5 @@
DIST lz4-0_p106.tar.xz 129352 SHA256 a9a09c4ebb962995d10e7e4f7d9224aaa93f308899de18a414948a58e87b6f22 SHA512 8b2bafbf78be7c42831e264d7acdca12712c88369cecdb3aa4621c84bb6b450c372f5153f7c3939a5f70d5810c62b98993697397319d286a1bb51b1e4a6ecde6 WHIRLPOOL fc5bb47b73606b125d8e155365d1fe101083e68e684ffd6014440e0f1416f1f6ecc64b797083e6939bd3e8cd42018e46a1864ae4542160c96933a47df9421a42
DIST lz4-1.7.5.tar.gz 208019 SHA256 0190cacd63022ccb86f44fa5041dc6c3804407ad61550ca21c382827319e7e7e SHA512 b4e5b17fe06805e676608e636a45f0b480b79a02c6b7ffce84dc4d607861cb2652b2852493ab9d9249e7caeae6f00b6834801fdc39f58d901cbc1c7347915295 WHIRLPOOL 961c56f36a78a4703403a95b54efed8fe859b7ae6327a1318112e322052655aa379e37c34a1d9e8f11397e4f3e14b5f1dfe60083e253dbf20fbbbbb753c28c1b
+DIST lz4-1.8.0.tar.gz 222840 SHA256 2ca482ea7a9bb103603108b5a7510b7592b90158c151ff50a28f1ca8389fccf6 SHA512 aea46d4a900a3ede7dd7b498ee938ecd98397d3277c5b3a85b4236a44777cba85cd68a2f32c993b872afda96c5dafe0cb3dd391101fe8181e17c9f48884c1535 WHIRLPOOL bb32fe1dde5466e4dc9a9144dba305c6bf57dc0b824063e14f87ed900e87c214598dc18562e4555cdca75d7cca705413c7458b1d0bf449cc3752fbfa1fdea009
DIST lz4-r120.tar.gz 161950 SHA256 fa02b1bcc26529c27cff0883d830914bdd1ba41a87035313e1050302f17e4b07 SHA512 8b27c57737ba4c2c8e4f00f7ce13f6edc91f74885bad66dd521dfe85d427e0fd78a300896d599bb8642a34fba78446daf207d1b2fd8e91543d4c093e53694e86 WHIRLPOOL 6a0cd7f8caf9799130b13b3f282197b5ef20fb987f0f5f6911f71a0f5d5d37c542976be5f13bdd2e21a8edd0a6cc8408fcc0f69f6354a0fbc7df75b22fb9de91
DIST lz4-r131.tar.gz 133784 SHA256 9d4d00614d6b9dec3114b33d1224b6262b99ace24434c53487a0c8fd0b18cfed SHA512 60bd95d529691ffee2c43f0d8a62484c3cff74c0154094f073192606806ac8182dced61e0534ffa7e0ccf5f18e9a8cfd2738883a83814c0711a6d7f1d1b252e5 WHIRLPOOL d605dbada1d4eb84eb6f3f45417eaa35433b1e3e875af560bb5fa06f0465f1652fab74c094d0d743e0034abc0067c83114827e21baea69d5c3d6d95062d0f660
diff --git a/app-arch/lz4/lz4-1.8.0.ebuild b/app-arch/lz4/lz4-1.8.0.ebuild
new file mode 100644
index 000000000000..93a775dff04e
--- /dev/null
+++ b/app-arch/lz4/lz4-1.8.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+# 1.7.5->1.8.0 has some minor changes; the only really incompatible
+# would be removing 'const' from LZ4F_freeDecompressionContext() arg
+# however, it is extremely unlikely that this 'const' would actually
+# be relied on
+SLOT="0/r131"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index a2eeb91e001e..267436933dac 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -19,8 +19,6 @@ HOMEPAGE="https://github.com/lz4/lz4"
LICENSE="BSD-2 GPL-2"
# https://abi-laboratory.pro/tracker/timeline/lz4/
-# note: abi-tracker is most likely wrong about 1.7.3 changing ABI,
-# the maintainer is looking into fixing that
SLOT="0/r131"
IUSE="static-libs"