summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lziprecover/lziprecover-1.18_pre1.ebuild')
-rw-r--r--app-arch/lziprecover/lziprecover-1.18_pre1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild b/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild
new file mode 100644
index 000000000000..f7dc48105a12
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for files in the lzip compressed data format"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}