summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pure-sfv/pure-sfv-0.3-r2.ebuild')
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r2.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r2.ebuild
new file mode 100644
index 000000000000..e10b8d93b4f1
--- /dev/null
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="utility to test and create .sfv files and create .par files"
+HOMEPAGE="https://pure-sfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin pure-sfv
+ newdoc ReadMe.txt README
+}