summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rzip/rzip-2.1-r5.ebuild')
-rw-r--r--app-arch/rzip/rzip-2.1-r5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/rzip/rzip-2.1-r5.ebuild b/app-arch/rzip/rzip-2.1-r5.ebuild
new file mode 100644
index 000000000000..cf8b6d722684
--- /dev/null
+++ b/app-arch/rzip/rzip-2.1-r5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Compression program for large files"
+HOMEPAGE="https://rzip.samba.org/"
+SRC_URI="https://rzip.samba.org/ftp/rzip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="app-arch/bzip2:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-darwin.patch
+ "${FILESDIR}"/${PN}-2.1-CVE-2017-8364.patch
+ "${FILESDIR}"/${PN}-2.1-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ ewarn "Warning: Gentoo shipped a broken rzip for quite some time. During"
+ ewarn "compression of large files it didn't set the right file size, so"
+ ewarn "if you have any reason to believe that your archive was compressed "
+ ewarn "with an old Gentoo rzip, please refer to "
+ ewarn " https://bugs.gentoo.org/217552"
+ ewarn "for the rzip-handle-broken-archive.patch patch to rescue your"
+ ewarn "data."
+ ewarn
+ ewarn "We apologize for the inconvenience."
+}