summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/unshield/unshield-0.6_p20120308.ebuild')
-rw-r--r--app-arch/unshield/unshield-0.6_p20120308.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/unshield/unshield-0.6_p20120308.ebuild b/app-arch/unshield/unshield-0.6_p20120308.ebuild
new file mode 100644
index 000000000000..781cc978e7e5
--- /dev/null
+++ b/app-arch/unshield/unshield-0.6_p20120308.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="http://github.com/twogood/unshield http://sourceforge.net/projects/synce/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/openssl:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467548
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-ssl
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+
+ find "${D}" -name '*.la' -exec rm -f {} +
+}