summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zpaq/zpaq-6.41.ebuild')
-rw-r--r--app-arch/zpaq/zpaq-6.41.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/zpaq/zpaq-6.41.ebuild b/app-arch/zpaq/zpaq-6.41.ebuild
new file mode 100644
index 000000000000..b3fe2f697a23
--- /dev/null
+++ b/app-arch/zpaq/zpaq-6.41.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Journaling incremental deduplicating archiving compressor"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="=app-arch/libzpaq-${PV}
+ dev-libs/libdivsufsort"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/${PN}-4-autotools.patch
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ # man-page is no longer there
+ ac_cv_prog_POD2MAN=
+ )
+
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+}