summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/duplicity/duplicity-0.7.16.ebuild')
-rw-r--r--app-backup/duplicity/duplicity-0.7.16.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-backup/duplicity/duplicity-0.7.16.ebuild b/app-backup/duplicity/duplicity-0.7.16.ebuild
deleted file mode 100644
index 0e550a7c893c..000000000000
--- a/app-backup/duplicity/duplicity-0.7.16.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="http://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="s3 test"
-
-CDEPEND="
- net-libs/librsync
- app-crypt/gnupg
- dev-python/fasteners[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- app-arch/par2cmdline
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="${CDEPEND}
- dev-python/paramiko[${PYTHON_USEDEP}]
- s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- # workaround until failing test is fixed
- local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
-
- distutils-r1_python_prepare_all
-
- sed -i "s/'COPYING',//" setup.py || die
-}
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- elog "Duplicity has many optional dependencies to support various backends."
- elog "Currently it's up to you to install them as necessary."
-}