summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/mkstage4/mkstage4-0.4.3.ebuild')
-rw-r--r--app-backup/mkstage4/mkstage4-0.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-backup/mkstage4/mkstage4-0.4.3.ebuild b/app-backup/mkstage4/mkstage4-0.4.3.ebuild
new file mode 100644
index 000000000000..690249b6cff2
--- /dev/null
+++ b/app-backup/mkstage4/mkstage4-0.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Bash Utility for Creating Stage 4 Tarballs"
+HOMEPAGE="https://github.com/TheChymera/mkstage4"
+SRC_URI="https://github.com/TheChymera/mkstage4/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-util/bats )"
+RDEPEND="
+ app-shells/bash
+ app-arch/tar
+"
+
+src_install() {
+ newbin cpstage4.sh cpstage4
+ newbin exstage4.sh exstage4
+ newbin mkstage4.sh mkstage4
+ einstalldocs
+}
+
+src_test() {
+ bats -r tests/* || die
+}