summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/mkstage4/mkstage4-9999.ebuild')
-rw-r--r--app-backup/mkstage4/mkstage4-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-backup/mkstage4/mkstage4-9999.ebuild b/app-backup/mkstage4/mkstage4-9999.ebuild
index cd989859f11f..d22f71fe4e1b 100644
--- a/app-backup/mkstage4/mkstage4-9999.ebuild
+++ b/app-backup/mkstage4/mkstage4-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit git-r3
@@ -15,10 +15,18 @@ KEYWORDS=""
IUSE=""
DEPEND=""
-RDEPEND="app-shells/bash
- app-arch/tar"
+RDEPEND="
+ app-shells/bash
+ app-arch/tar
+"
src_install() {
+ newbin cpstage4.sh cpstage4
+ newbin exstage4.sh exstage4
newbin mkstage4.sh mkstage4
einstalldocs
}
+
+src_test() {
+ bats -r tests/* || die
+}