summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/sarab/files/README.gentoo (renamed from app-backup/sarab/files/README.Gentoo)0
-rw-r--r--app-backup/sarab/sarab-1.0.0.ebuild29
2 files changed, 16 insertions, 13 deletions
diff --git a/app-backup/sarab/files/README.Gentoo b/app-backup/sarab/files/README.gentoo
index 46359913c729..46359913c729 100644
--- a/app-backup/sarab/files/README.Gentoo
+++ b/app-backup/sarab/files/README.gentoo
diff --git a/app-backup/sarab/sarab-1.0.0.ebuild b/app-backup/sarab/sarab-1.0.0.ebuild
index 6c426c2c9cbd..896edbcc95c8 100644
--- a/app-backup/sarab/sarab-1.0.0.ebuild
+++ b/app-backup/sarab/sarab-1.0.0.ebuild
@@ -1,38 +1,41 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit eutils
+EAPI=6
+
+inherit readme.gentoo-r1
DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR"
HOMEPAGE="http://sarab.sourceforge.net/"
SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=""
-RDEPEND="app-backup/dar
+RDEPEND="
+ app-backup/dar
virtual/mailx"
-src_unpack() {
- cd "${S}"
- unpack ${A}
-
- epatch "${FILESDIR}"/${PV}-better-defaults-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${PV}-better-defaults-gentoo.patch )
src_install() {
dobin sarab.sh
+ einstalldocs
+
insinto /etc/sarab
- doins -r etc/*
+ doins -r etc/.
# sarab.conf could contain passphrase information
fperms 600 /etc/sarab/sarab.conf
- dodoc CHANGELOG FAQ INSTALL README
- dodoc "${FILESDIR}"/README.Gentoo
+
+ readme.gentoo_create_doc
}
-pkg_postinstl() {
+pkg_postinst() {
+ readme.gentoo_print_elog
+
ewarn "The configuration format for DAR encryption has changed in Sarab 0.2.4."
ewarn "Replace DAR_ENCRYPTION_OPTIONS=\"--key blowfish:PASSPHRASE\""
ewarn "by SARAB_KEY=\"blowfish:PASSPHRASE\" in /etc/sarab/sarab.conf"