summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/acovea')
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1-r2.ebuild47
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch8
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch4
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch4
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch4
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch4
6 files changed, 59 insertions, 12 deletions
diff --git a/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild b/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild
new file mode 100644
index 000000000000..ed0e2b0232d9
--- /dev/null
+++ b/app-benchmarks/acovea/acovea-5.1.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
+HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
+SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ >=dev-libs/libcoyotl-3.1.0:=
+ >=dev-libs/libevocosm-3.3.0:=
+ dev-libs/expat:="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-asneeded.patch
+ "${FILESDIR}"/${P}-free-fix.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+ "${FILESDIR}"/${P}-glibc-212.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-libevocosm.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
index 8bfb8a175550..3a887c15888c 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
@@ -1,13 +1,13 @@
---- cmdline/Makefile.am
-+++ cmdline/Makefile.am
+--- a/cmdline/Makefile.am
++++ b/cmdline/Makefile.am
@@ -7,4 +7,4 @@
runacovea_SOURCES = runacovea.cpp
-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lexpat
+LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
---- libacovea/Makefile.am
-+++ libacovea/Makefile.am
+--- a/libacovea/Makefile.am
++++ b/libacovea/Makefile.am
@@ -16,3 +16,5 @@
library_include_HEADERS = $(h_sources)
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
index 55b3b00e8897..e20bfa3eb98f 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
@@ -1,5 +1,5 @@
---- benchmarks/treebench.c
-+++ benchmarks/treebench.c
+--- a/benchmarks/treebench.c
++++ b/benchmarks/treebench.c
@@ -201,8 +201,8 @@
if (page->m_links[n] != NULL)
recursive_destroy_page(page->m_links[n]);
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
index c5e5392b2f99..2207f4616426 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-gcc44.patch
@@ -1,5 +1,5 @@
---- libacovea/acovea.cpp
-+++ libacovea/acovea.cpp
+--- a/libacovea/acovea.cpp
++++ b/libacovea/acovea.cpp
@@ -44,10 +44,11 @@
#include <unistd.h>
#include <sys/types.h>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch b/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
index 9763951a672a..996cb5ebc82e 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-glibc-212.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/336260
---- libacovea/acovea.cpp
-+++ libacovea/acovea.cpp
+--- a/libacovea/acovea.cpp
++++ b/libacovea/acovea.cpp
@@ -44,6 +44,7 @@
#include <unistd.h>
#include <sys/types.h>
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
index f801b8c68bcb..46ddb5fe4d97 100644
--- a/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-libevocosm.patch
@@ -1,5 +1,5 @@
---- libacovea/acovea.cpp
-+++ libacovea/acovea.cpp
+--- a/libacovea/acovea.cpp
++++ b/libacovea/acovea.cpp
@@ -86,7 +86,7 @@
// randomize settings of this option
void option::randomize()