summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bashmark/bashmark-0.6.2.ebuild')
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
new file mode 100644
index 000000000000..571160233f73
--- /dev/null
+++ b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Geno's cross platform benchmarking suite"
+HOMEPAGE="http://bashmark.coders-net.de"
+
+SRC_URI="http://bashmark.coders-net.de/download/src/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_install() {
+ dobin bashmark
+ dodoc ChangeLog
+}