summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild b/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild
new file mode 100644
index 000000000000..b37e43482f30
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.96-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+SRC_URI="http://www.coker.com.au/bonnie++/experimental/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile-flags.patch
+}
+
+src_configure() {
+ econf \
+ $(use_with debug) \
+ --disable-stripping \
+ || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav || die
+ dobin bon_csv2html bon_csv2txt || die
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt credits.txt
+}