summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bootchart2')
-rw-r--r--app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild5
-rw-r--r--app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch24
2 files changed, 27 insertions, 2 deletions
diff --git a/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild b/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild
index 6cd79686f3af..fe460f6fbd0a 100644
--- a/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild
+++ b/app-benchmarks/bootchart2/bootchart2-0.14.9-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
inherit linux-info python-single-r1 systemd toolchain-funcs
@@ -31,6 +31,7 @@ CONFIG_CHECK="~PROC_EVENTS ~TASKSTATS ~TASK_DELAY_ACCT ~TMPFS"
PATCHES=(
"${FILESDIR}"/${PN}-0.14.8-no-compressed-man.patch
+ "${FILESDIR}"/${P}-glibc-2.36.patch
)
src_prepare() {
diff --git a/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch b/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch
new file mode 100644
index 000000000000..720079e9d794
--- /dev/null
+++ b/app-benchmarks/bootchart2/files/bootchart2-0.14.9-glibc-2.36.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/864205
+https://github.com/xrmx/bootchart/commit/8591c1e3edaea8f17396e3d2819d9064b2818cfb
+
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 6 Aug 2022 20:39:01 -0700
+Subject: [PATCH] Do not include linux/fs.h
+
+This header is not needed to be included anymore, moreover it conflicts
+with sys/mount.h from glibc 2.36+ see [1]
+
+[1] https://sourceware.org/glibc/wiki/Release/2.36
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/collector/collector.c
++++ b/collector/collector.c
+@@ -34,7 +34,6 @@
+
+ #include <sys/mount.h>
+ #include <sys/sysmacros.h>
+-#include <linux/fs.h>
+ #include <linux/genetlink.h>
+ #include <linux/taskstats.h>
+ #include <linux/cgroupstats.h>
+