summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/i7z')
-rw-r--r--app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch4
-rw-r--r--app-benchmarks/i7z/i7z-93_p20131012-r1.ebuild4
-rw-r--r--app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild2
3 files changed, 5 insertions, 5 deletions
diff --git a/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch b/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
index 72695a951f7e..d521674af6cc 100644
--- a/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
+++ b/app-benchmarks/i7z/files/i7z-0.27.2-ncurses.patch
@@ -7,7 +7,7 @@ Index: Makefile
CC ?= gcc
-LIBS += -lncurses -lpthread -lrt -lm
-+LIBS += `pkg-config --libs ncurses` -lpthread -lrt -lm
++LIBS += `$(PKG_CONFIG) --libs ncurses` -lpthread -lrt -lm
INCLUDEFLAGS =
BIN = i7z
@@ -16,7 +16,7 @@ Index: Makefile
#http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=644728 for -ltinfo on debian
static-bin: message $(OBJ)
- $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ) -static-libgcc -DNCURSES_STATIC -static -lpthread -lncurses -lrt -lm -ltinfo
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ) -static-libgcc -DNCURSES_STATIC -static -lpthread `pkg-config --static --libs ncurses` -lrt -lm
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN) $(OBJ) -static-libgcc -DNCURSES_STATIC -static -lpthread `$(PKG_CONFIG) --static --libs ncurses` -lrt -lm
# perfmon-bin: message $(OBJ)
# $(CC) $(CFLAGS) $(LDFLAGS) -o $(PERFMON-BIN) perfmon-i7z.c helper_functions.c $(LIBS)
diff --git a/app-benchmarks/i7z/i7z-93_p20131012-r1.ebuild b/app-benchmarks/i7z/i7z-93_p20131012-r1.ebuild
index d555d4c41fa5..20080024b0f3 100644
--- a/app-benchmarks/i7z/i7z-93_p20131012-r1.ebuild
+++ b/app-benchmarks/i7z/i7z-93_p20131012-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -45,7 +45,7 @@ src_configure() {
# Looks to work fine for me with -O2 (pacho - 20170530)
# filter-flags "-O*"
- tc-export CC
+ tc-export CC PKG_CONFIG
cd GUI || die
use qt5 && eqmake5 ${PN}_GUI.pro
diff --git a/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild b/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
index 992080972ba0..b31f97afeca6 100644
--- a/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
+++ b/app-benchmarks/i7z/i7z-93_p20131012-r2.ebuild
@@ -40,7 +40,7 @@ PATCHES=(
S="${WORKDIR}/${PN}-${COMMIT}"
src_configure() {
- tc-export CC
+ tc-export CC PKG_CONFIG
cd GUI || die
use qt5 && eqmake5 ${PN}_GUI.pro
}