summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/interbench/interbench-0.31-r1.ebuild')
-rw-r--r--app-benchmarks/interbench/interbench-0.31-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-benchmarks/interbench/interbench-0.31-r1.ebuild b/app-benchmarks/interbench/interbench-0.31-r1.ebuild
new file mode 100644
index 000000000000..f52495b10492
--- /dev/null
+++ b/app-benchmarks/interbench/interbench-0.31-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A Linux interactivity benchmark"
+HOMEPAGE="https://github.com/ckolivas/interbench/"
+SRC_URI="https://github.com/ckolivas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+DOCS=(
+ "readme"
+ "readme.interactivity"
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-musl.patch"
+)
+
+src_prepare() {
+ default
+
+ # Inline will fail, if optimizations are turned off
+ append-cflags -std=gnu89
+
+ tc-export CC
+}
+
+src_install() {
+ dobin interbench
+ doman interbench.8
+
+ einstalldocs
+}