summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping/files/ioping-0.6-makefile.patch')
-rw-r--r--app-benchmarks/ioping/files/ioping-0.6-makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/files/ioping-0.6-makefile.patch b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
new file mode 100644
index 000000000000..b5836696e9f4
--- /dev/null
+++ b/app-benchmarks/ioping/files/ioping-0.6-makefile.patch
@@ -0,0 +1,26 @@
+ Makefile | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index b3d741e..79022e9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+-CFLAGS+=-std=c99 -g -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+-LDFLAGS=-lm
+-PREFIX=/usr/local
++CFLAGS+=-std=c99 -Wall -Wextra -pedantic -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
++LIBS=-lm
++PREFIX?=/usr/local
+ BINDIR=$(PREFIX)/bin
+ MAN1DIR=$(PREFIX)/share/man/man1
+
+@@ -30,7 +30,7 @@ install: $(BINS) $(MANS)
+ $(CC) $(CFLAGS) -DVERSION=\"${VERSION}\" -c -o $@ $^
+
+ ioping: $(OBJS)
+- $(CC) -o $@ $^ $(CFLAGS) $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ dist: $(DISTDIR).tar.gz
+