summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/ioping/ioping-1.3.ebuild')
-rw-r--r--app-benchmarks/ioping/ioping-1.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-benchmarks/ioping/ioping-1.3.ebuild b/app-benchmarks/ioping/ioping-1.3.ebuild
new file mode 100644
index 000000000000..d466ce4f1b5c
--- /dev/null
+++ b/app-benchmarks/ioping/ioping-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple disk I/0 latency measuring tool"
+HOMEPAGE="https://github.com/koct9i/ioping"
+SRC_URI="https://github.com/koct9i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+
+ dodoc changelog README.md
+}