summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/iozone/iozone-3.488.ebuild')
-rw-r--r--app-benchmarks/iozone/iozone-3.488.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-benchmarks/iozone/iozone-3.488.ebuild b/app-benchmarks/iozone/iozone-3.488.ebuild
index 3f6941869e61..eeac2f98f9eb 100644
--- a/app-benchmarks/iozone/iozone-3.488.ebuild
+++ b/app-benchmarks/iozone/iozone-3.488.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 arm ~ia64 ppc ppc64 ~riscv ~sparc x86"
S="${WORKDIR}/${PN}${PV/./_}"
@@ -32,15 +32,19 @@ src_configure() {
tc-export CC
case ${ARCH} in
- x86|alpha) PLATFORM="linux";;
- arm) PLATFORM="linux-arm";;
- ppc) PLATFORM="linux-powerpc";;
- ppc64) PLATFORM="linux-powerpc64";;
- amd64) PLATFORM="linux-AMD64";;
- ia64) PLATFORM="linux-ia64";;
- s390) PLATFORM="linux-S390";;
- *) PLATFORM="linux-${ARCH}";;
+ x86|alpha|riscv) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ ppc64) PLATFORM="linux-powerpc64";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-ia64";;
+ s390) PLATFORM="linux-S390";;
+ *) PLATFORM="linux-${ARCH}";;
esac
+
+ # makefile uses $(GCC) in a few places, probably
+ # by mistake.
+ export GCC="$(tc-getCC)"
}
src_compile() {