summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/libc-bench/files')
-rw-r--r--app-benchmarks/libc-bench/files/respect-flags.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-benchmarks/libc-bench/files/respect-flags.patch b/app-benchmarks/libc-bench/files/respect-flags.patch
new file mode 100644
index 000000000000..19958fd1c91b
--- /dev/null
+++ b/app-benchmarks/libc-bench/files/respect-flags.patch
@@ -0,0 +1,23 @@
+diff -Naur libc-bench-20110206.orig//Makefile libc-bench-20110206/Makefile
+--- libc-bench-20110206.orig//Makefile 2011-01-31 02:13:00.000000000 -0500
++++ libc-bench-20110206/Makefile 2012-08-09 22:12:24.000000000 -0400
+@@ -2,8 +2,7 @@
+ SRCS = $(sort $(wildcard *.c))
+ OBJS = $(SRCS:.c=.o)
+
+-CFLAGS = -Os
+-LDFLAGS = -static
++LDFLAGS += -static
+ LIBS = -lpthread -lrt -lpthread
+
+
+@@ -12,9 +11,6 @@
+ clean:
+ rm -f $(OBJS) libc-bench
+
+-test: all
+- ./libc-bench
+-
+ libc-bench: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+