summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/nbench')
-rw-r--r--app-benchmarks/nbench/metadata.xml11
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r2.ebuild (renamed from app-benchmarks/nbench/nbench-2.2.3-r1.ebuild)21
2 files changed, 18 insertions, 14 deletions
diff --git a/app-benchmarks/nbench/metadata.xml b/app-benchmarks/nbench/metadata.xml
index f8bd6f3f34f9..959b73bb0eb4 100644
--- a/app-benchmarks/nbench/metadata.xml
+++ b/app-benchmarks/nbench/metadata.xml
@@ -1,8 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>jer@gentoo.org</email>
- <name>Jeroen Roovers</name>
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
</maintainer>
+ <longdescription>
+ NBench, later known as BYTEmark, is a synthetic computing benchmark program
+ developed in the mid-1990s by the now defunct BYTE magazine
+ intended to measure a computer's CPU, FPU, and Memory System speed.
+ </longdescription>
</pkgmetadata>
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r2.ebuild
index 7a02dfbc8f62..7d013f96c0fc 100644
--- a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
+++ b/app-benchmarks/nbench/nbench-2.2.3-r2.ebuild
@@ -1,32 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit toolchain-funcs
+EAPI=8
MY_P="${PN}-byte-${PV}"
+inherit toolchain-funcs
+
DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="freedist"
SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ~mips ppc ppc64 sparc x86"
-IUSE=""
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}/${P}-Makefile.patch" )
src_prepare() {
default
- sed \
- -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
- -i sysinfo.sh || die "patching sysinfo.sh failed"
+ sed -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
+ -i sysinfo.sh || die
+
sed -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' \
- -i nbench1.h || die "patching nbench1.h failed"
+ -i nbench1.h || die
}
src_configure() {