summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/pipebench/files')
-rw-r--r--app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
new file mode 100644
index 000000000000..2d79d80ef7bc
--- /dev/null
+++ b/app-benchmarks/pipebench/files/pipebench-0.40-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,16 +1,11 @@
+ # $Id: Makefile,v 1.2 2002/12/15 19:58:36 marvin Exp $
+
+-CC=gcc
+-CFLAGS=-Wall -w -pedantic
+
+ all: pipebench
+ doc: pipebench.1
+ install: pipebench
+- cp pipebench /usr/local/bin/
+- cp pipebench.1 /usr/local/man/man1/
+-
+-pipebench: pipebench.c
+- $(CC) $(CFLAGS) -o pipebench pipebench.c
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/bin && cp pipebench $(DESTDIR)$(EPREFIX)/usr/bin/
++ mkdir -p $(DESTDIR)$(EPREFIX)/usr/share/man/man1 && cp pipebench.1 $(DESTDIR)$(EPREFIX)/usr/share/man/man1/
+
+ pipebench.1: pipebench.yodl
+ yodl2man -o pipebench.1 pipebench.yodl