summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/stress/stress-0.18.6.ebuild')
-rw-r--r--app-benchmarks/stress/stress-0.18.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-0.18.6.ebuild b/app-benchmarks/stress/stress-0.18.6.ebuild
new file mode 100644
index 000000000000..42dd6b178dfe
--- /dev/null
+++ b/app-benchmarks/stress/stress-0.18.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic
+
+MY_P="${PN}-${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Imposes stressful loads on different aspects of the system"
+HOMEPAGE="http://people.seas.harvard.edu/~apw/stress"
+SRC_URI="http://weather.ou.edu/~apw/projects/stress/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc ppc64 ~sparc x86"
+IUSE="static"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS README
+}