summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/stress/stress-1.0.4-r2.ebuild')
-rw-r--r--app-benchmarks/stress/stress-1.0.4-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-benchmarks/stress/stress-1.0.4-r2.ebuild b/app-benchmarks/stress/stress-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..41adb494631e
--- /dev/null
+++ b/app-benchmarks/stress/stress-1.0.4-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="A deliberately simple workload generator for POSIX systems"
+HOMEPAGE="https://people.seas.harvard.edu/~apw/stress"
+SRC_URI="https://people.seas.harvard.edu/~apw/${PN}/${P}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static)
+ )
+
+ econf "${myeconfargs[@]}"
+}