summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/Manifest2
-rw-r--r--app-benchmarks/siege/siege-3.0.6.ebuild49
-rw-r--r--app-benchmarks/siege/siege-3.1.3.ebuild52
3 files changed, 0 insertions, 103 deletions
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index 856e8d6a9090..0357b73a4e13 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1,4 +1,2 @@
-DIST siege-3.0.6.tar.gz 496002 BLAKE2B b21ed07a36b3e0ae5b4166f2d1351be790261d149bcac98f4d2795796e42a8697bf618822792f6f7c912be29d926cf5f8d3de443498deab8c553217db359d282 SHA512 621f3f60f2aac70fb051f48819f5673d60f31fc4fc69e4c65d4ae0a285d02112686f1e9b40241d48afc378446a2b296a7dc4bbc6d8ae38e390d380506f4d448b
-DIST siege-3.1.3.tar.gz 527862 BLAKE2B 9cc10b5afa15c5a7682452d8a4020de62c195192abcb222c36d148da871693c1fcf5be2e3d1a3ca1c4a7fd39fda505520f40ee053ca50fd15340441a498e368f SHA512 880b6d8bbe6b8210147ebb26fd724f4c242076740284977471165fbca514b56c49812ace42dcbe23c57be8fd10a2503b129deec10b79991451a9ae83f30a742b
DIST siege-3.1.4.tar.gz 530149 BLAKE2B 3721387fa1ace745ce7748612849b84c07e84456bd903460930ab407cba1e24f493d4a251bacd3e509aafbc653e5d74e96509bf74f0a2a8066a0ec2b7ad2e9ee SHA512 8e8b4c1e9c20833f4c3538e8929e47d1c9113cd1faf395e5f07734fb7f4291061cb7554cf500a80d8b1b6be0d6f4c8194b054f632f35533837220702784ee068
DIST siege-4.0.4.tar.gz 523102 BLAKE2B 2d69dd37fea7ff35e05b41d500d4efb5b4fe60d9389b7bd98ec360148af781a24b6ebaa213b59ffc36cfcc8421efea14d8ec9f5742a53e019b2221584b5af17e SHA512 a8361ac0e2514626d794e7e4a345b178462409a1f3b53a9318adf171b511c408508acdb07652ad38f34021ac4a614dc5e6d2ea3c6a4ffd261ceef36d3226e573
diff --git a/app-benchmarks/siege/siege-3.0.6.ebuild b/app-benchmarks/siege/siege-3.0.6.ebuild
deleted file mode 100644
index 1002d516d110..000000000000
--- a/app-benchmarks/siege/siege-3.0.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-#WANT_AUTOMAKE=1.9
-
-inherit eutils bash-completion-r1 libtool autotools
-
-DESCRIPTION="A HTTP regression testing and benchmarking utility"
-HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
-SRC_URI="http://www.joedog.org/pub/siege/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ~mips ppc x86 ~x64-macos"
-SLOT="0"
-IUSE="ssl"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- # bundled macros break recent libtool
- sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
- rm *.m4 || die "failed to remove bundled macros"
- eautoreconf
-}
-
-src_configure() {
- local myconf
- use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
- econf ${myconf}
-}
-
-src_install() {
- make DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
- doc/siegerc doc/urls.txt
-
- newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
-}
-
-pkg_postinst() {
- echo
- elog "An example ~/.siegerc file has been installed in"
- elog "${EPREFIX}/usr/share/doc/${PF}/"
-}
diff --git a/app-benchmarks/siege/siege-3.1.3.ebuild b/app-benchmarks/siege/siege-3.1.3.ebuild
deleted file mode 100644
index b08e5a9b4f55..000000000000
--- a/app-benchmarks/siege/siege-3.1.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-#WANT_AUTOMAKE=1.9
-
-inherit eutils bash-completion-r1 libtool autotools
-
-DESCRIPTION="A HTTP regression testing and benchmarking utility"
-HOMEPAGE="https://www.joedog.org/siege-home/"
-SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~x86 ~x64-macos"
-SLOT="0"
-IUSE="libressl ssl"
-
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_prepare() {
- # bundled macros break recent libtool
- sed -i -e 's/AC_PROG_SHELL//' configure.ac || die
- rm *.m4 || die "failed to remove bundled macros"
- eautoreconf
-}
-
-src_configure() {
- local myconf
- use ssl && myconf="--with-ssl=${EPREFIX}/usr" || myconf="--without-ssl"
- econf ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog INSTALL README* KNOWNBUGS \
- doc/siegerc doc/urls.txt
-
- newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
-}
-
-pkg_postinst() {
- echo
- elog "An example ~/.siegerc file has been installed in"
- elog "${EPREFIX}/usr/share/doc/${PF}/"
-}